hyoromoのブログ

iOS/AndroidもしくはCocos2dxネタを書いています

たのしいCocoaプログラミング

会社の人から借りている「たのしいCocoaプログラミング」を読みながら試していきます。

Xcode Toolsインストール

実は前にXcodeのインストールは済ませてあったので、ここは飛ばします。

Xcode起動

さっそく以下のアプリを起動してみます。
/Developer/Applications/Xcode.app

Application Specific Information:
objc[290]: '/System/Library/PrivateFrameworks/DebugSymbols.framework/Versions/A/DebugSymbols' was not compiled with -fobjc-gc or -fobjc-gc-only, but the application requires GC
objc[290]: *** GC capability of application and some libraries did not match

いきなりエラー!?
なぜ?試しにXcode Toolsを再インストールしても直らない。


で、よくよく調べたらSafari4ベータをインストールしたことによって、何かしらのバージョンがアップされたようです。
結果、Xcodeとの互換性に問題が生じ、エラーとなった。
参考サイトによるとXcode Toolsの最新版をインストールしなければならないらしい。
http://discussions.apple.com/thread.jspa?threadID=1918554&tstart=0
これが迂闊に新しいものに飛びついた者の末路ですね。

Xcode Tools3.1.2をインストール

わざわざADCのオンライン会員になって、最新版をインストールしてきましたよ。
無事インストール完了し、Xcode.appを起動してみると・・・正常に起動できました!
「たのしいCocoa」じゃなく、「つまらんCocoa」になるところでした。